Home > Ati Drivers > Ati Drivers For Spore

Ati Drivers For Spore

And it ran like crap once I got to land. Edit: Just been fiddling with the settings on the OS X version of Spore. I suspect this is a driver issue, considering that I can't even remember the last time a new driver came out for the X1900 / Intel combo. (ATI/AMD are pretty much depending on the OP's res though, it could be an issue... http://tbapplication.com/ati-drivers/ati-drivers-8-8.html

I also made sure I downloaded the newest drivers from AMD's website. EA are obviously well aware of the situation so there should be some solution soon as I hate having to boot back and forth into bootcamp. @ babyjenniferLB Oh and yeah share Share on Twitter Share on Facebook Email Link Like + Quote Reply QCassidy352, Sep 5, 2008 QCassidy352 macrumors G3 Joined: Mar 20, 2003 Location: Bay Area #14 babyjenniferLB said: ↑ Useful Searches Recent Posts Options Please select a forum to jump to News and Article Discussion MacRumors.com News Discussion Mac Blog Discussion

Works fine on my macbook on high, so this is a bit strange (running under winXP) . share Share on Twitter Share on Facebook Email Link Like + Quote Reply padré, Sep 4, 2008 padré thread starter macrumors regular Joined: Aug 7, 2006 #9 re in europe its Bad gaming experience. If you didn't download the latest version, I strongly suggest you do so.The ATI GPU will play quite nicely with the Nvidia chipset based mobo.

Will try the fix mentioned above. left click the advanced button 5. I was wondering the same thing, especially since it's not available for sale yet. That's what I was about to link to.

Offline warmslime wrote: LeopardoDeVinci wrote:Will Intel graphics cards, even the latest versions, work? Shoot - well, EA, i won't be buying this until Apple releases a fix...does anyone know if it affects JUST OS X? Any update from ATI that will solve this problem? Now it loads up just fine.

Following advice I saw on this thread, I turned the lighting setting down to "low", and this fixed the problem. This message was edited 1 time. For computers using built-in graphics chipsets, the game requires at least: * Intel Integrated Chipset, 945GM or above. * 2.6 GHz Pentium D CPU, or 1.8 GHz Core 2 Duo, or Not an issue.Also, do as Timop suggests, regardless of where you got your drivers.

spore isnt that intense, ive played the demo on a X800GTO (even more inferior than the X1900, at least 2x slower if not more) and it played well at 1280x1024, max http://www.gamespot.com/articles/spore-hardware-performance-guide/1100-6197428/ Ia anyone playing Spore on a 2.4 Ghz iMac with the ATI 2600, and how does it run? The game used to crash right after the first cutscene finished. Sometimes I select the driver folder and it doesn't even recognize it as a driver that will work with my video card.

by left clicking 8. his comment is here Then downgrade to 8.12 and then install the hotfix for it. I want so bad. I am not surprised that Spore will run with no problems on systems using nVidia cards.

If this doesnt work your problem lies elsewhere. I was so disappointed. Clean the drivers, then install the current drivers. this contact form thanks sidereal says: December 24, 2010 at 03:21 Awesome.

Great framerates; no problems. The fact that they were released, 9.1, 9.2, and 9.3 so close together indicates a lot of tweaking going on. ATI or Nvidia chipset Ati vc on nvidia chipset Can't find your answer ?

Its probably not ATI's problem, but a bug in the Spore coding for mac.

To fix this problem do a complete express uninstall of the ATi driver. It should be fixed in the future. Install .NET framework 1.1 3. EA says that an OS X update will fix the problem, but Apple controls that rollout." John.Click to expand...

These problems were easily seen when looking at the Sporpidia section. The drivers were extracted to your hard drive in C:\NVIDIA\Win2k\177.92, but the setup did not install them. Yes, my password is: Forgot your password? http://tbapplication.com/ati-drivers/ati-drivers-zip.html When launching the game, some Microsoft Vista users may receive a warning about running out of address space along with a link to the Microsoft Knowledge Base.

I did have to disable the 6250 onboard video to make it work.Good luck! A New Mac Pro is Coming! i went a week trying to figure out what was going on. All Rights Reserved.

Run RefreshForce and setup some resolutions you want to use on each monitor. fecker4, Sep 19, 2008 #1 fecker4 New Member Joined: Sep 19, 2008 Messages: 11 Likes Received: 0 Trophy Points: 0 Update Update: According to the Version checker, the one driver that Most likely your bottle neck there is that antiquated ATi Radeon X1900 its a bit on the low end these days, try shopping around for a X2800 or X3870 both have It ran Prey on high settings last year, for chrissakes.

I'm wondering if I should splurge a wee bit and get a GTX 460. i have 2 gig ram, a ati 1900 in a mac pro :s anybody else expierencing the same (it runs smooth when i put all the settings verry low) share gimme a break, the x1900 is still better than many of the mid-range cards out there, and should be able to run a not-too-demanding game like Spore easily. Thanks Craig craig5320, Sep 24, 2008 #6 (You must log in or sign up to reply here.) Show Ignored Content Share This Page Log in with Facebook Log in with

You can follow any responses to this entry through the RSS 2.0 feed. Thanks. I wanted to leave a comment on your post regarding a simple little Midnight Club 2 patch here: http://www.nicolaspeople.com/ch3rokeesblog/?p=33 Just wanted to say THANK YOU!